8.0rc1 Runtime Tutorial

I’m currently trying to go through the tutorials here to get a feel for cylc, before giving it a shot to sequence a climate modelling system. The scheduling tutorial worked great, but when I try to load the example for the run-time tutorial, the documentation doesn’t seem to be consistent with the available commands in my conda environment.

Specifically, when I try to run

cylc get-resources tutorial

I get

cylc get-resources: unknown utility. Abort.
Type "cylc help all" for a list of utilities.

I tried looking at the output of cylc help all, I saw extract-resources and cylc extract-resources tutorial even gives some files (i.e. an etc directory in $PWD ) but they don’t seem to be what the tutorial lays out.

Am I missing something, or is this utility not actually available? Just in-case it was an installation problem, I included details on how I installed cylc into a conda environment below on a Ubuntu 20.0.4 system.


My environment

To install cylc into a virtual environment, I followed the directions here, but when I ran conda install -c conda-forge cylc-flow, the installation process stalled on Solving environment so I eventually did this:

conda create -name cylc-test python=3 conda-forge::cylc-flow

this worked, so I was able to install the other optional dependencies via:

conda install -c conda-forge cylc-uiserver
conda install -c conda-forge cylc-rose metomi-rose

but then needed to manually rollback markupsafe to 2.0.1 via pip install markupsafe==2.0.1 in order to get around a bug in that module.


What version does Cylc report when you run cylc version?

Hey Oliver thanks for the response - I guess my responses didn’t get posted while my main post was still being reviewed!

The issue was definitely caused by my conda environment installing the beta version - after I updated conda and installed using the recommended environment file, I got the 8.0rc1 version and managed to get the tutorial resources

1 Like

Hi @Clint_Seinen

Pleased to hear you got this sorted.

Actually there is no moderation process on this forum. Posts should show up immediately, but yours got categorized as possible spam for some reason. Sorry about that.

Note also, the markupsafe dependency issue was discussed in another thread: Cylc 8.0rc1 gui fails due to markupsafe ImportError - #2 by oliver.sanders