Reload isn't updating my task when I resubmit it

I seem to keep hitting this problem, and sometimes it’s been user error, but I’m pretty sure not always!

(This is a cylc 8 suite that I’ve been writing from scratch, as per my earlier posts…)

  1. I update my task definition by adding an environment variable
  2. I reinstall/validate/reload (which I now have a script to do so I don’t forget to validate)
  3. I trigger the failing task I’m trying to fix
  4. The new job script does not show the changes
  5. I run cylc config to check the parsed config has the changes and it does.
  6. I repeat steps 1-5, with the same result. Several times. With various minor suite changes like adding in dummy variables, to have something to do.

I stopped and restarted the suite, and the changes were picked up. (At least this time…)

I used to think this only happened after I’d been reloading the suite repeatedly, but in this case I had just restarted the suite, and it didn’t pick up the new change from the start. Certainly I seem to hit this issue on most of the occasions I find a bit of time to play with cylc8.

Any idea why reload is ineffectual at times?

I realise this is probably hard to reproduce. It’s not even a consistent problem, since it works for me sometimes. I’m not sure what other diagnostics I can look at to help you understand what is happening. I am using cylc 8.0.1


This issue should be fixed in the latest release (8.0.3):

okay, hopefully! I’m not using compatibility mode (if that’s what you were thinking) but hopefully one of those fixes works for me.
I’ll update when I get a chance to try the new release.

There were a few reload/submission related fixes in 8.0.2 & 8.0.3 which collectively should solve the issue, fingers crossed. If you still see this problem with 8.0.3, please get back to us and we’ll investigate. To capture evidence try running the workflow in debug mode e.g. cylc play --debug <id>.